Discussioni utente:Atsirlin

Da Wikivoyage.
Jump to navigation Jump to search


Benvenuto[modifica]

Ciao Atsirlin!

Benvenuta/o su Wikivoyage in lingua italiana! Stiamo realizzando un'attendibile guida turistica mondiale libera e aggiornabile. Aiutaci anche tu! Se hai appena conosciuto Wikivoyage e non sai come funziona e in che modo puoi aiutarci, poni le tue domande nella Lounge, il punto d'incontro dei wikiviaggiatori, oppure consulta le nostre pagine di aiuto.

Potrai trovare risposte ai tuoi dubbi anche nelle pagine delle domande frequenti e dei consigli per i nuovi arrivati.

Ricordati soprattutto che è vietato copiare testi protetti da copyright. Il nostro obiettivo non è proporre contenuti copiati da altri siti, ma scrivere una nuova guida turistica di nostro pugno.
Wikivoyage-Logo-v3-en.svg


--Andyrom bot (discussioni) 19:38, 28 mar 2013 (CET)

Help with Listing Editor needed[modifica]

I'll try to have a look. --Andyrom75 (discussioni) 14:28, 27 feb 2015 (CET)

Apparently you configuration is correct, so I suppose that you have introduce a bug in the customized code.
Review you changes to see where the mistake is. --Andyrom75 (discussioni) 14:50, 27 feb 2015 (CET)

Wiki Loves Earth 2017[modifica]

My email is: mamot50@alice.it Thank you. --Massimo Telò (scrivimi) 21:39, 1 mag 2017 (CEST)

I noted it down. Thanks! --Atsirlin (discussioni) 21:40, 1 mag 2017 (CEST)

[modifica]

When someone change a banner on it:voy is supposed to change also the relevant description. Who is not familiar with Italian language should ask to a native speaker to take it in charge to avoid dicrepancy between the new image and the old description. --Andyrom75 (discussioni) 10:31, 2 dic 2017 (CET)

Sorry, I did not know that. --Atsirlin (discussioni) 10:33, 2 dic 2017 (CET)
That's what I supposed and that's why I told you ;-) Don't worry, I've just fixed it. --Andyrom75 (discussioni) 10:35, 2 dic 2017 (CET)

Wikivoyage map[modifica]

Hi Atsirlin, I'm disturbing you because I've seen that you are one of the maintainers of the wmflabs tools for Wikivoyage. Since we got some problems with the php script created by Mey2008. At that time I've supported him on its development. Since arisen some bugs I need a couple of things:

  1. get access to be able to modify that script in order to be autonomous in the medium/long term ... how can I do?
  2. get your support (if you are available) to try to fix those bugs in the short term

Let me know, --Andyrom75 (discussioni) 21:38, 28 mag 2020 (CEST)

Andyrom75, I added you to the list of maintainers. However, I have not been working with these tools lately and can't provide any immediate support. --Atsirlin (discussioni) 22:20, 28 mag 2020 (CEST)
Thanks for this first step. I've created a new account in wmflabs and my "Membership requests" is still pending. In the meanwhile, I've tried to find where the source codes are located without success. Do you have a direct link to share? --Andyrom75 (discussioni) 22:45, 28 mag 2020 (CEST)
Let me be more specific. I'm not familiar at all with toolsadmin and I've used Phabricator only for opening ticket. I've been only able to browse the repository from Phabricator but I don't know how to edit the scripts (i.e. submit changed versions). Maybe I have to be included in the editor list but still I need to understand which is the procedure. Unfortunately this part was in charge of Mey2008 and I have no experience. Could you help me? --Andyrom75 (discussioni) 14:53, 29 mag 2020 (CEST)
Finally I was able to configure git and access in reading to the wikivoyage repository but I confirm that I do not have the edit rights, infact I got this error message: "Exception: You do not have permission to push to this repository. Please make sure you have the correct access rights and the repository exists.". Are you able to grant it to me or do I have to open a Phab ticket? Let me know, --Andyrom75 (discussioni) 18:17, 29 mag 2020 (CEST)
You are the maintainer and you have all possible rights. I guess I can't tell you more right now, because it is the first long weekend in 3 months when we can travel somewhere and enjoy the life, so I am going to be off for the next few days. Sorry. --Atsirlin (discussioni) 22:08, 29 mag 2020 (CEST)
Don't worry and enjoy the life you and everyone deserve :-) By the way just for your information, you can see that on this link there are 8 maintainers, but on this link only 3 out of 8 are allow to edit the files. In the meanwhile I'll try to get some help from other sources, but after your restoring weekend, if you'll see the same status, please support me on get edit right. Thanks, --Andyrom75 (discussioni) 20:14, 30 mag 2020 (CEST)
I've been added as editor in the diffusion repository and I'm able to modify the source code in Phabricator through GIT. Unfortunately I'm still not able to modify anything on the running code inside tools.wmflabs.org/wikivoyage. I've tried to configure PuTTY withouth success. What do you use? Any suggestion? --Andyrom75 (discussioni) 13:35, 5 giu 2020 (CEST)
Ping :-) --Andyrom75 (discussioni) 14:38, 12 giu 2020 (CEST)
Hi Atsirlin, sorry for bothering you again, but I really need help to access to those files. Please let me know if you or anyone you know can support me on that. Thanks, --Andyrom75 (discussioni) 09:36, 24 giu 2020 (CEST)
Hi Andyrom75. Briefly you should
1) generate SSH keys pair (private + public key) - on Windows use PuTTYgen shipped with PuTTY
2) save private key to a file on your computer, put public key to https://toolsadmin.wikimedia.org/profile/settings/ssh-keys/ (copy "Public key for pasting into authorized_keys file" from PutTTYgen)
3) start SSH session with PuTTY, specifying path to your private key (at "Connection" - "SSH" - "Auth") and <your-login>@tools-login.wmflabs.org (replace <your-login> with an actual login) as hostname.
Please let me know once you've logged into the server, then we will check how to manage files on the server. And let me know if you have any problems when using SSH. --AlexeyBaturin (discussioni) 11:08, 24 giu 2020 (CEST)
Thanks AlexeyBaturin for your kind reply. I've followed your steps but I'm not able to established a connection. Let me give you more details on what I've done.
1) With PuttyGen I've created an RSA 2048 bytes key, storing in the same folder the "puttyPUB" and "puttyPRI.ppk" files.
2) I've copied the public text that I've found in the textbox of the PuttyGen app into toolsadmin.wikimedia.org. Note that:
2.1) I've already had 2 other keys in the site
2.2) The content of "puttyPUB" file it's not identical to what I've copied (maybe it's just comments, but I've highlighted in any case)
3) In "SSH->Auth" I've specified where "puttyPRI.ppk" is located. For the login I've tried in two ways:
3.1) Setting "Andyrom75@tools-login.wmflabs.org" into "Connection->Data->Auto-login username"
3.2) Leave that field blank
3bis) in both cases in "Session->Saved Sessions" I've selected (Load) "Andyrom75@tools-login.wmflabs.org" and then Open (connection type SSH). In both 3.1 and 3.2 cases I got the same fatal error: "No supported authentication method available (server sent:publickey.hostbased)".
Any idea on what I've done wrongly or at least what I should do differently? --Andyrom75 (discussioni) 15:12, 24 giu 2020 (CEST)
Andyrom75, 2.1 and 2.2 are ok, you could have multiple keys, and key format actually differs for PuTTY client and other software like OpenSSH used by the server. That's not a problem. I see 2 possible issues starting from 3. First, I'm not sure that "Andyrom75" is correct login, personally my login (abaturin) differs from my wiki login (AlexeyBaturin). Do you have any other login? Then, saved sessions could be a problem. Try to use the following exact sequence: 1) Open PuTTY 2) Go to "SSH" - "Auth" and specify private key path there. 3) Go to "Session" 4) Type "Andyrom75@tools-login.wmflabs.org" at "Host Name" field 5) Click "Open". That's all, nothing more, no saved sessions. --AlexeyBaturin (discussioni) 16:51, 24 giu 2020 (CEST)
Correct login should be taken from https://toolsadmin.wikimedia.org/profile/settings/accounts/ - see "UNIX shell username" under "Wikimedia developer account" section. --AlexeyBaturin (discussioni) 16:53, 24 giu 2020 (CEST)
AlexeyBaturin, thanks again. I've checked in toolsadmin.wikimedia.org and I've seen my Wikimedia developer account:
  • Username: Andyrom75
  • UNIX shell username: andyrom75
I've understood that my mistake was to use capitol "A" instead of lower "a". Finally I'm in! :-) Now I have correctly updated the saved session, so I can perform all the previous steps in just one click.
Now before proceeding with the next steps, let me just share you one fact. Recently I've created another account "Andyrom 75" (with the space) and I got the bed idea to connect my Wikimedia and Phabricator accounts to it instead of this one. Is it a problem? In any case how can I switch this connection? I wasn't able to find any option. --Andyrom75 (discussioni) 22:20, 24 giu 2020 (CEST)
Andyrom75, I have no idea, I'm not familiar with account details for Wikimedia/Phabricator, but I think you would have to do everything from the beginning - recreate/re-link accounts, configure SSH keys and so on.
Now to put new files into the tool you have 2 options:
1) Get familiar with Linux shell commands like cd/ls/cp/mv/rm (to manage files), git (to download data from a git repository), wget/curl (to download files by HTTP) and so on. There is toolforge specifics: to get into specific tool after you've logged in by SSH, you have to execute "become <tool-name>" command, e.g. "become wikivoyage". Data is located at "/data/project/<tool-name>", e.g. "/data/project/wikivoyage"
2) Use WinSCP or FileZilla: I've just found an detailed instruction with screenshots https://wikitech.wikimedia.org/wiki/Help:Access_to_Toolforge_instances_with_PuTTY_and_WinSCP, and it seems that WinSCP is the most suitable option.
The second way seems to be more simple, but I've never tried it myself. I suggest you to try and let us know the results. --AlexeyBaturin (discussioni) 21:23, 25 giu 2020 (CEST)
AlexeyBaturin, I'm familiar on moving around Linux directories, because around 20ys ago I got one PC with Linux. Notwithstanding this, I'm not familiar with git/wget/curl, if fundamental please give some very basic info. However my target now is to download a file, change on my laptop because it's easier for me, and upload it again. Can I do it from command line or do I have to use WinSCP? --Andyrom75 (discussioni) 18:33, 26 giu 2020 (CEST)
Andyrom75, configuring WinSCP once would save your time in the future. Still, if you need to copy just one file, you could use pscp utility which is normally shipped with PuTTY. To copy a file using pscp, start Windows Command Line and run command like "pscp.exe -i <full-path-to-your-private-key> andyrom75@tools-login.wmflabs.org:<full-path-to-a-remote-file> <full-path-to-a-local-file>", e.g. "pscp.exe -i C:\my-key.ppk andyrom75@tools-login.wmflabs.org:/data/project/wikivoyage/my-file.php C:\my-file.php" (not sure about exact syntax, don't have a Windows box ATM, but I think that should work). If you get something like "command not found" error, specify full path to pscp.exe, like "C:\Program Files\PuTTY\pscp.exe" or smth like that. --AlexeyBaturin (discussioni) 19:32, 26 giu 2020 (CEST)
AlexeyBaturin, at the end I've installed WinSCP and luckly it recognized the Putty session I've created configuring itself automatically :-) I was able to download the whole remote project directory in my local PC, but I'm not able to upload (through drag&drop) a script that I've created locally into the remote directory. It says: Permission denied. Error code: 3 Error message from server: Permission denied.
In the link you suggested me, it talks about similar error and it says to perform these commands:
$ become wikivoyage
$ chmod -R g+w /data/project/wikivoyage
but since I'm not sure about the result, I'm reluctant to proceed. Do I grant only to the users in Wikivoyage group the write permission, or to any user? --Andyrom75 (discussioni) 23:13, 26 giu 2020 (CEST)
Andyrom75, have you specified the following option in WinSCP settings as recommended by the instruction:
sudo -u tools.PROJECT-NAME /usr/lib/sftp-server
Anyway, if the way above does not work for any reason, you could upload files under your account using WinSCP (e.g. to /home/andyrom75/myfile.txt), then copy by "cp /home/andyrom75/myfile.txt /data/project/wikivoyage/myfile.txt", then run "become wikivoyage", and finally "take /data/project/wikivoyage/myfile.txt". That should give correct permissions to the file. --AlexeyBaturin (discussioni) 19:56, 28 giu 2020 (CEST)
AlexeyBaturin, your support is priceless; finally everything works! Now comes the time to debug the script :-) --Andyrom75 (discussioni) 21:47, 28 giu 2020 (CEST)